JavaScriptがオンになっていないとご利用できません。

lepton

Lepton2

trino

Trino

titan

TITAN

atom

atom

arki

Arki

プリンターに接続できず、ファーム再書き込みもできず

Posted by くも
Posted Jul 12, 2014 - 2:26 AM 

はじめまして
本日キットが届き、早速組み立てました。
しかしUSBポートは正常に認識しPrintrunでもポートの存在は確認できるのですが、接続が全くできません。
一度USBを抜き、プリンター側も電源再投入で再起動した後で再度接続しても現象としては変わりませんでした。
また、ファーム再書込を試みるもArduinoIDEにてprogrammer is not respondingが出てしまいます。

使用環境はMacOS10.9.4
ArduinoIDEは1.0.5
です。

必須
 確認してチェック
5 reply
View 1168
Posted by くも
Posted Jul 13, 2014 - 4:09 PM

momoinololuに最初にインストールしてあるブートローダーに何を使っているのか調べたのですが見当たらなかったのです
調べ方が悪いのかもわかりませんが

とりあえず動かすということで、1284Pを載せたSanguinololu 1.3bで使えるブートローダーを探したのですが、やっぱりx軸が逆転しないとかベリファイで引っかかるなんかで中々見つからず
結果として
https://github.com/jmgiacalone/sanguino1284p
だとFuse設定関連に問題なく動作することが確認できました
ファーム再書込の時にもしかしたら間違って設定変えてしまったかもしれません

今のところ動作自体はうまいこといっているので細かい調整やっていくことにします

Posted by Hironao Kato
Posted Jul 13, 2014 - 1:11 PM

どうもです! 

ブートローダーが見つからないのですか、ちょっと史上初ですね。

もしご自分でなんとかなる場合はSanguinoブートローダーです。

こちらの方でもご交換できますので、ご連絡いただければ幸いです!

Posted by くも
Posted Jul 13, 2014 - 1:27 AM

返信ありがとうございます
一応確認してみましたが導通は取れているようです
どうもリミット三つ全て効いてないようです
モーターもx軸だけ逆転ができません
症状としては
http://reprap.org/wiki/Sanguinololu#Bootloader
にあるヒューズ設定の問題がほぼそのままです
一度ブートローダー自体を書き直そうと思います

ただmomoinololuに使われているブートローダーを調べたのですが、どうにも見つかりません
sanguinoブートローダーで問題無いのか、gen7が入っているのか

Posted by Chimura Hiroki
Posted Jul 12, 2014 - 4:34 PM

おそらくX軸のエンドストップスイッチの根元がしっかり刺さっていないかと、黒いスイッチの根元に白いものが刺さっているのですが、挿し込みが甘いとXホームボタンを押しても10mmくらいづつ逆走する現象が起こります。

Posted by くも
Posted Jul 12, 2014 - 4:05 AM

すみません、解決しました
今までFTDIドライバ無しでシリアル周り使ってきたのですが
ドライバ入れないと認識はするけど使えない場合があるのですね

マニュアル操作ができるようになったのでひと通り動作をさせてみたのですが、何故かX軸だけ一方方向にしか回転しません
またリミットまで達してもモーターが止まりません
ファーム書き直しも試しましたが効果はありませんでした
リミットの方はconfigの方で何とかなるかもしれないのですが、どうもモーターが逆転しない現象の対処法がわかりません
ご教示いただければ幸いです

5 reply
View 1168

東京都港区東麻布1-4-2 THE WORKERS&CO 401

facebook/genkei.japan

@Genkei1