JavaScriptがオンになっていないとご利用できません。

lepton

Lepton2

trino

Trino

titan

TITAN

atom

atom

arki

Arki

モータードライバーの調整について

Posted by INAGAKI
Posted Jun 20, 2018 - 11:13 PM 

TAITAN3 デュアルヘッドを1年くらい使っています。

X軸の積層ズレが発生しているので、モータードライバーの調整にチャレンジしようと思ったのですが。。。

解説ビデオとWIKIのページを見て混乱しています。

基本的なことで申し訳ないですが、モータードライバーは一つのモーターにつき一つなのですよね。。

TAITAN3 のボードを見ると、解説ビデオと同じく、二つのドライバーが設置されています。このドライバーはエクストルーダー用のように見えるのですが、X軸を調整しようとするときは、どうすればいいのでしょうか?

X軸Y軸のモーターの裏には基盤が装着されているので、ここにドライバーがあるのでしょうか?

そうだとすると、どこで電圧をはかり、調整するのかがわかりません。

ちなみにボードに装着されていたドライバーはいずれも1.59V程度でした。

 

必須
 確認してチェック
5 reply
View 285
Posted by azusa9
Posted Jun 26, 2018 - 6:36 PM

T0,T1両方使うプリントだと調整が難しいですよね。

私のTITAN3もデュアル仕様なんですが、ほとんどデュアルで使っていなくてうろ覚えですが、ツールチェンジスクリプトの中でノズルごとの高さの調整が出来ます。

ただ、私はデフォルトからコマンドを色々書き換えているのですが、私は、M206というコマンドを使って、オフセット設定を入れて使っています。

; {IF OLDTOOL =1}G1 Z-0.2 F500

; {IF OLDTOOL =1}G4 P200

; {IF OLDTOOL =1}G1 Z0.4 F1000 ;Z Move amount of T1-T0

; {IF OLDTOOL =1}G92 Z[current_position_z]

この辺りのコマンドをコメントアウトして

 

; T0-T1

{IF OLDTOOL =1}M206 Z-0.45

; T1-T0

{IF NEWTOOL =1}M206 Z0

こんな感じです。ただ、上手く動いたような、動かなかったような不安な記憶しか無いので使う時はご注意下さい。もしグローバルオフセットが設定されているときは、こちらのコマンドで上書きされてしまうと思うので、より注意が必要です。

Posted by INAGAKI
Posted Jun 26, 2018 - 9:18 AM

azusa9さん

ありがとうございます。少し前に別トピックで移動速度の調整について教えていただいていたので、それかなと対応してみました。前回のトピックのときは移動速度=プリント速度と勘違いしてました(^^)

造形物が大きいと移動距離が大きくなり、慣性によりドライブの重量に対してマグネットの吸着力が負けてしまうのかと。

私のTAITAN3はマグネットの裏に補強用?のマグネットが付いてるのでけど、これをもう少し吸着力の高いものに変えると効果あるかも。

移動のとき以外にも、ドライブが脱落することが頻繁に起こるようになりました。

少し前に、T0のホットエンドを変えたときに、Zのレベルが必要でした。このとき、T1の方とのズレが生じてしまうのでは?と思ったのですが、SimplfyではノズルのオフセットはXYしかないように見えたのですが、調整方法ご存知ですか?

因みに、今はラフトを使ってるのですが、脱落はたまに起こってしまっています。

Posted by azusa9
Posted Jun 25, 2018 - 12:09 PM

>XYのムーブメントスピードを100から60に落としたところ結構解消されました。

>TAITAN3 デュアルヘッド

と言う事なので、おそらくマグネットでホットエンドを脱着する所がスピードに負けて動いてしまっているのかなと思います。私の手元のTITAN3でも早くしすぎると時々起きます。なので移動速度は80mm/sec程度を上限にプリント設定を作っています。

ベッドとノズルの間の調整を少しゆるめにすると、発生しにくくなるかも知れません。その時はラフトを付けるようにすると緩くて取れると言う事はある程度防げるかなと思います。

もしかしたらマグネットの所にゴミが入っているかも知れませんので、それは一度確認されたらと思います。(触ってざらついていないか)

ノイズとかの可能性もあると思いますので、色々試されると良いと思います。

Posted by INAGAKI
Posted Jun 21, 2018 - 10:14 PM

加藤さん、ありがとうございます。

1. ノイズを拾っていてずれている

2. プーリーが緩んでいないか

3. クローズドループのルックアップテーブルがずれているのではないか

2はかなり確認したのでないかと思います。

1.は確認してみます。

3.の可能性があるとして、それはファームウェアのアップデートで解消されるのでしょうか?

XYのムーブメントスピードを100から60に落としたところ結構解消されました。

左の写真が100のとき、右の写真が60に落としたときです。

これらの外周は170mmくらいですが、外周から内側、内側から外周へとヘッドが移動するときにズレが生じているような感じです。以前は100(既定値)でもここまでズレは生じなかったと記憶しています。

 

Posted by Kato
Posted Jun 21, 2018 - 6:51 PM

TITANの場合は制御ボードのXYZからそれぞれモータードライバに渡してありますが、

一部のモーターは外部大型になっていると思います 特にZが大型になっていると思います。

 

さてXYはクローズドループ基板になっているのでそもそも電圧調節は外部からは行えません。

X軸がずれているとなると恐らくですがノイズを拾っていてずれているかまたはプーリーが緩んでいないか、またはクローズドループのルックアップテーブルがずれているのではないかなと思います。

 

ノイズが原因の場合は特にホットエンドを加熱する際にノイズが発生します。 

ノイズが原因かどうかの判定は ホットエンドを両方加熱し T0でもT1でもいいのでヘッドをX軸を+100㎜など一度稼働させ 保持トルクを発生さえてみましょう。 220度で加熱している際に制御ボードが温度調節のためにLEDがチカチカすると思います。 

その時にノイズが原因の場合X軸のモーターが チリッ チリッ と定期的に微動している場合ノイズの可能性があります。

エクストルーダーのフラットケーブルにもフェライトコア処理をしてみるとどうでしょう

https://www.amazon.co.jp/ELECOM-%E3%82%A8%E3%83%AC%E3%82%B3%E3%83%A0-%E9%AB%98%E5%91%A8%E6%B3%A2%E3%83%8E%E3%82%A4%E3%82%BA%E5%90%B8%E5%8F%8E%E3%82%B9%E3%83%BC%E3%83%91%E3%83%BC%E3%83%95%E3%82%A7%E3%83%A9%E3%82%A4%E3%83%88%E3%82%B3%E3%82%A2%CF%865-0-%CF%868-7%E5%AF%BE%E5%BF%9C-NF-59S/dp/B00008B3J2

 

また、以前は造形できていたけど最近ズレが発生している場合はノイズではない可能性大です。

その場合X軸のモータードライバ自体のファームウェアをアップデートしてみると良いかと思います。

ファームウェアとインストール方法のマニュアルはMagnaRectaに直接メールしたほうが良いと思います。

 

 

5 reply
View 285

東京都港区東麻布1-4-2 THE WORKERS&CO 401

facebook/genkei.japan

@Genkei1